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Product Description 1
Product Description

PC Interface
ez-Attendant is a software application designed to enhance the attendant functionality of the 
TeleniumIP by visualizing the Attendant call handling and control functions.

ez-Attendant works in conjunction with the Attendant's multi-button phone providing 
enhanced attendant functionality and efficiency.
The user interfaces with the ez-Attendant screen, Figure 1, using the mouse (point and 
click) or programmable Hot Keys to select features and functions available.
A pop-up Incoming Call window notifies the user of incoming calls while working with 
other applications (word processor, spread sheet, etc.). 

Database Functionality
ez-Attendant incorporates a database for internal users and external contacts and shares the 
System Speed Dial data with the TeleniumIP system.

The database entries can be searched and used to place calls.
The external contact database can be linked to a private or shared Personal Information 
Management (PIM) database including Outlook, Goldmine or ACT!.
Daily schedules of internal extension users with access to public Outlook files can be 
shared, and displayed on the ez-Attendant screen.

Figure 1: ez-Attendant Screen
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2 Installation
Installation

Installing the ez-Attendant is a four (4) step process, you will need to perform the following:
1) License ez-Attendant on the TeleniumIP system using an unlock code purchased from Vodavi,
2) Install the ez-Attendant application on the desired PC,
3) Configure the ez-Attendant program,

-and-
4) Connect the ez-Attendant PC to the host TeleniumIP system.

NOTE: After configuring ez-Attendant, the ez-Attendant PC should be restarted to ensure all 
configuration information is available in active memory.

PC Requirements
The ez-Attendant application software requires a PC with the minimum configuration as defined 
below:

Pentium III
800 MHz CPU
256 M Bytes of RAM
100 M Bytes of HDD storage
17" monitor with a resolution of 1024 x 768
Microsoft Windows 2000 or XP operating system
10/100 Base T NIC (Network Interface Card)
CD ROM drive
Standard Keyboard

Standard Mouse

System Requirements

Port Connection

ez-Attendant is designed to work with the TeleniumIP system that must be equipped with a LAN 
port for connecting to the ez-Attendant application. A LAN port is standard on both the MFIM 
and MFIME which makes ez-Attendant compatible with both Vodavi TeleniumIP systems.

Software Version

The TeleniumIP Main Processor Board (MPB) must be equipped with software version 2.2Fi or 
later.

IP Address

The TeleniumIP must have a fixed (static) IP address. For security purposes, a private IP 
address is recommended. The ez-Attendant PC will support static or dynamic IP addressing.

Multiple Systems

ez-Attendant will operate in a network environment where several TeleniumIP systems are 
interconnected. In the network environment, the BLF Manager server, which runs on a 
separate PC, provides status information on up to 50 extensions of each network node to
ez-Attendant.
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Installation 3
Installation Routine
Install the ez-Attendant application on to a computer using the CD provided. The installation 
routine uses an Auto Run program that will start when the CD is placed in the CD ROM drive. 

DAO Install

1. Once the CD launches, 
Windows will determine 
whether or not you already 
have the DAO (Database 
Access Object) interface files 
installed on your computer. If 
you don’t, the InstallShield 
Wizard will present the dialog 
box shown in Figure 2.

2. Click Yes to install the DAO 
files needed by ez-Attendant to 
access the database programs 
on your computer.

» If the DAO dialog box does 
not appear, skip to the ez-
Attendant Install procedure.

3. From the "DAO Setup" screen, click Next to continue.
4. If you are unsure which selection to choose (Jet 3.5 or ODBCDirect), both components 

may be installed. When finished, click Next.
5. If the Jet component was chosen, select the desired programs (Excel, Lotus, etc.) and 

click Next. Again, if you are unsure, select all the components.

» After installing the DAO components, the ez-Attendant Wizard will appear, Figure 3.

ez-Attendant Install

1. After the "Welcome" screen 
displays, click Next to start the 
installation program.

2. Select the setup type for 
"Vodavi Communications" and 
click OK.

3. Choose the destination folder 
or accept the default location 
and click OK.

4. Once the installation process is 
complete, click NO when asked 
to restart your computer.

5. From the "WinCap Setup" 
screen, click OK to continue.

6. Select "I Agree" to accept the License Agreement and click OK.
7. When the installation is complete, click Finish to exit the wizard.
8. Restart your computer before configuring the ez-Attendant program.

» For proper communication, it will be necessary to install a “software lock-key” in the 
TeleniumIP system.

Figure 2: DAO Install

Figure 3: ez-Attendant Wizard
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4 ez-Attendant Configuration
ez-Attendant Configuration

Navigating in the Program Window
The ez-Attendant main program window will allow you to access the settings shown in the 
following sections:

File Menu

Log Off
New Database > New MS Access / New MS Excel
Import DB > MS Outlook Contact / MS Outlook Schedule /
                   Goldmine / ACT! /MS Access / MS Excel
Export DB > MS Contact / Goldmine / ACT! / MS Access /

MS Excel
Print Setup
Print
Exit

Tools Menu

Station Name Change
Select Message Type
Paging
Music Selection
Date/Time
SMS > Private SMS / Mobile SMS
Attendant > Change COS / Temporary COS / Attendant Cancel
PrePaid Call
Conference Room Manager

Setting Menu

Customized Message
Wake Up Setting
Record VMIB
Send Mail
Group Setting
Selected Station View
Flex Buttons Setting
Code Setting
Keymap
Customize
Option

Help Menu

About ez Attendant
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ez-Attendant Configuration 5
Program Overview
After successfully installing the ez-
Attendant application, the program will 
need to be configured for optimum 
performance.
With the program open … the Display 
and Settings windows may be 
accessed from the Main Menu bar 
under: Setting / Option. Refer to 
Figure 4 and Figure 5.

The Display window will allow the 
user to select certain display options 
to modify the way the program looks.

Station Type (buttons/list)
Station Window Size (S, M, L)
Station View
Park Call Display (show/hide)
Keypad Display (where to appear)
Toolbar ICON Display (Wakeup, 
Recorder icons)
Language Selection (not supported)

Figure 4: ez-Attendant Display Window

The Settings window contains 
specific system parameters, such as: 
the IP address of the TeleniumIP system 
LAN port, and the Attendant extension 
number which must be set for proper 
communication.

System Setting for LogOn
Log On Information (IP Address/Extn)
SMS Information (short messages)
Forward Information (where to appear)
Group Setting Information 
(department/names)

» As shown, these windows are 
divided into multiple sections and 
are described in the following 
paragraphs in the order displayed.

» Additional configuration items from 
other dialog boxes are also covered 
in this section.

Figure 5: ez-Attendant Settings Window
EZ Attendant - Installer & User Guide October 2006



6 ez-Attendant Configuration
Display Window
» To access the Display window from the Menu bar, select: Setting > Options > Settings tab

Station Type

The Station window in the ez-Attendant main screen is primarily used as a status display of the 
host system and, if assigned, the network TeleniumIP stations. The Station window is also used 
to display the ez-Attendant Phone Book and to view call logs by selecting the appropriate tab to 
the right of the window. When used in the Station Field view, the display indicates the status 
of internal stations and allows the Attendant to call individual stations by selecting the 
desired station button.
For convenience, under the Station Field tab, stations can be displayed in one of three Types 
(or views): Large Icon buttons, Small Icon buttons, and List View, Figure 6.

The Large Icon view displays the name and number for each station, and a phone icon 
which is used to indicate the status of the extension.
The Small Icon view shows the station number and a smaller phone icon to indicate 
extension status.
The List View displays each extension in a list format that shows the name, number and 
other user related phone numbers, as well as a small phone icon for status of extension.

Figure 6: Station Button & List View Displays

Large
Button

List
View

Small
Button
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ez-Attendant Configuration 7
Station Window Size

The size of the Station Window can be adjusted to “small, medium or large” which will 
increase or decrease the number of button rows or list items displayed. The number of rows 
displayed is based on the Station Window size, and the Station Type selected for the default 
screen resolution (1024 by 768 XGA), Table 1. For both large and small icon views, seven (7) 
columns of station icons are displayed.

The view and size are configured in the Station Type and Station Window Size sections of the 
Display window, Figure 7. 

For the Station Type, select the radio button for the view desired:
- Large Button Type = large icon display
- Small Button Type = small icon display
- List Type = list display
For the Station Window Size, select the radio button desired for the number of rows that 
will be displayed for each selection: Small, Middle or Large. Refer to Table 1.
Click Apply to save the selection and to allow further entries,
-or-
Click OK to save the selection and return to the ez-Attendant main screen.

 

Figure 7: Station Window Display Mode

Table 1: Station Window Size

Station
Window Size

Station Type
(Rows/Buttons displayed)

Large Icon Small Icon List

Small 4/28 8/56 13

Middle 5/35 10/70 18

Large 6/42 12/84 21

As the size of the Station window is increased, the size of the System Text Message, Schedule and 
SMS (Short Message Service) windows will be decreased.
EZ Attendant - Installer & User Guide October 2006



8 ez-Attendant Configuration
>>>> Station View

The Station window displays stations by groups. The active group display is selected from the 
tabs at the top of the Station Window. The available Groups are based on the group 
(department) name in the internal Phone Book, or a single group of “selected stations”. The 
user can select to view stations by group name or by selected station.

Selecting View by Group Name will display stations by the department name registered on 
the Phone Book. Refer to Station Window Display Groups on page 13 to add/edit the names 
of Group members.

Choosing View by Select Station, the ez-Attendant displays stations selected by user as shown:
Click the radio button with View by Select Station text to display selected stations, Figure 
8. After selecting View by Select Station, stations can then be assigned to the selected 
station’s group.

Figure 8: View by Select Station option

To select stations for monitoring; select Setting from the Main Menu, choose "Selected 
Station View" from the Setting Menu, select stations for monitoring and select  to add 
them to the Selected Station List. Select the Close button to store the selection and exit, 
Figure 9.

Figure 9: Select Station window

When complete, the Station Window will display the “ALL Group” and “Selected Stations” 
tabs as shown in Figure 3.4.1.2c and will not display stations by the Group (department) 
name. Figure 3.4.1.2c Select station view Button View Number/Name Sort 
When the Button Type view is selected, the buttons can be displayed and sorted by extension 
number or name. When sorted by number, the lowest station number is shown in the upper 
left and the highest is shown in the lower right. When sorted by name, the buttons are sorted 
in alphabetical order by first name. To change the sorting option, right-click in the Station 
Window and select Sort By Name, or Sort By Number.
Figure 3.4.1.3a Popup Menu on the station window / Figure 3.4.1.3b Station window sorted 
by name / Notes: The default sort order is by Number.
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ez-Attendant Configuration 9
Park Call Display Window

The Park Call Display window displays information on calls that are “parked” by ez-Attendant. 
The information included is the Park Zone and the caller Id for the parked call. The window 
will be shown just above the Lower Tool bar. By default, the Call Park window is not 
displayed. ez-Attendant may be configured to show this window from the Park Call Display 
section in the Display window, Figure 10.

Click the desired radio button to select “Show or Hide” the Park Call window.
Click Apply to save the selection and to allow further entries,
-or-
Click OK to save the selection and return to the ez-Attendant main screen.

Figure 10: Call Park Display option

Keypad Display

ez-Attendant can display a “telephone keypad” which the attendant can use to place internal or 
external calls in place of the Attendant's multi-button phone. The keypad is displayed in 
either the Information or Queue window based on the option selected in the Keypad Display 
section of the Display window, Figure 11.

Click the desired radio button to show the keypad in the Information or Queue window.
Click Apply to save the selection and to allow further entries,
-or-
Click OK to save the selection and return to the ez-Attendant main screen.

Figure 11: Keypad Display option

Language Selection (not available)

The default language for the ez-Attendant application is English. The “Local Language” option is 
not available or supported at this time.

It is recommended that the Keypad be displayed in the Information window.

Hunt Groups can not be assigned a button in the Station window therefore; the keypad is used to 
place a call to a station Hunt Group.
EZ Attendant - Installer & User Guide October 2006



10 ez-Attendant Configuration
Settings Window
After installing the ez-Attendant, the user must select the proper target system to log on.
» To access the Settings window from the Menu bar, select: Setting>Options>Settings tab

System Setting for LogOn

Select the applicable TeleniumIP system from the drop-down "System" menu.
Click Apply to save the selection and to allow further entries,
-or-
Click OK to save the selection and return to the ez-Attendant main screen.

Figure 12: System Setting for Logon

CONDITIONS

» The TeleniumIP system can only be changed when no users are logged on to the ez-Attendant.

Log On Information

The IP Address of the host TeleniumIP system and the Attendant extension number are 
required data and must be assigned in the Log On Information section of the Settings 
window, Figure 13.

Enter the IP address of the host TeleniumIP system and the extension number of the 
Attendant station associated with ez-Attendant.
Click Apply to save the selection and to allow further entries,
-or-
Click OK to save the selection and return to the ez-Attendant main screen.

Figure 13: Log On Information in Option Window

» The “Port” entry in the Log On Information section is the fixed UDP port used for communication 
between ez-Attendant and the TeleniumIP.

» ez-Attendant supports the Hot-Desk feature of the TeleniumIP.   In this case, enter the appropriate Hot 
Desk extension number for the Attendant No in this section. Then, to log-on, the Attendant must enter 
the associated Hot-Desk password.
EZ Attendant - Installer & User Guide October 2006



ez-Attendant Configuration 11
CONDITIONS

TeleniumIP Settings
» Each ez-Attendant in a TeleniumIP system, maximum five, must have a separate extension 

number based on the TeleniumIP Attendant assignments (PGM 164 or 120).
» If the ez-Attendant Password Login setting is ON, the designated station(s) will be required 

to use a password when entering the ez-Attendant. The password is the station number you 
are connecting ez-Attendant to followed by the code set in the Authorization Code Table 
(PGM 227) for that station. This password is the same as the one used for VSF voice mail.

LogOn Fail Error Message

- If you receive the pop-up message "LogOn Fail", it means you have not used a valid 
product license code on the TeleniumIP system.

- If you have been using ez-Attendant during the introductory demonstration period without a 
permanent license, and receive this message, the demonstration timer has expired.

Contact your Vodavi dealer to correct the problem.

SMS Information

ez-Attendant can send short text messages (48 characters) to other ez-Attendants, ez-Phones, 
VODAVI multi-button display telephones and VODAVI DECT phone displays.

The “Master PC” will function as the SMS server.
The configuration includes selection of the SMS server (Master PC) and the IP address 
of the Master PC.

In the SMS Information section, select either the Master or Client PC box as appropriate.
For the Master PC, …
For a Client PC, enter the IP address of the Master PC.

 

Figure 14: SMS Information Dialog Box
 

GSM Messaging settings may appear in your version of ezAttendant, however they do not apply to 
North American applications. SMS messaging is only available within the TeleniumIP system.
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12 ez-Attendant Configuration
Forward Information

When required, the Attendant may forward calls to another Attendant or extension in the 
host TeleniumIPsystem without the need to Log Off. The extension to receive calls is predefined 
in ez-Attendant. When activated by selecting Forward on the Lower Tool bar, all ez-Attendant calls 
are forward to the extension assigned in the Forward Information section of the Settings 
window, Figure 15.

Enter the extension number to receive calls forwarded from ez-Attendant in the Forward No 
box.
Click Apply to save the selection and to allow further entries,
-or-
Click OK to save the selection and return to the ez-Attendant main screen.

Figure 15: Forward Information 

CONDITIONS

» The ez-Attendant extension must be allowed to activate Call Forward in the host TeleniumIP 
system database and is subject to the conditions of the TeleniumIP.

Group Setting Information

When groups are defined as departments, the company name can be defined in the Group 
Setting Information section of the Settings window, Figure 16.

Enter the company name in the Company box.
Click Apply to save the selection and to allow further entries,
-or-
Click OK to save the selection and return to the ez-Attendant main screen.

Figure 16: Group Setting Information
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ez-Attendant Configuration 13
Other Functions

Station Window Display Groups

When the ez-Attendant is configured to display stations by group name, refer to >>>> Station 
View on page 8, the Station Window will provide tabs at the top of the window for each group 
that was entered in the internal Phone Book. When a tab is selected, the stations assigned to 
that group are displayed as shown in Figure 17.
The Group Display feature is most commonly used to identify departments: Sales, Human 
Resources, Stockroom, etc. Also, when ez-Attendant is used in a network environment with the 
DSS/BLF Manager, special groupings are assigned for stations of network nodes.

Figure 17: Station Window Group Tabs

» To display or modify group assignments, Figure 18, go to the Menu bar and select: 
Setting > Group Setting.

Figure 18: Group Setting Dialog Box
EZ Attendant - Installer & User Guide October 2006



14 ez-Attendant Configuration
Groups are shown in the left window; members (system users) are shown in the right 
window.

In the Group box the Group name can be entered or edited. Group details can be 
expanded in the Group window to show group members or hidden, displaying only the 
group name.
In the Member window, the member names can be searched by entering characters in 
the Member box. The Member window can be sorted by the station number or the user 
name by selecting the appropriate column header (Stn No or Name).

To enter or remove a member for a group:

1. Enter the group name in the Group box, or select a group in the Group window.
2. Select a member name in the Member window.
3. Select  to add the selected member to the group or  to remove the member.

When Group Names are added or edited, the change is automatically updated in the 
internal Phone Book.

CONDITIONS

» There is no limit to the number of groups that can be defined.
» In a network environment, separate Groups can be defined for network stations. A 

network group may contain stations from any combination of network nodes.
» When the Group Setting dialog box is closed, Groups that have no members assigned will 

be deleted automatically.
EZ Attendant - Installer & User Guide October 2006



ez-Attendant Configuration 15
Hot-Key Map Configuration

The Attendant may use keyboard shortcuts or Hot Keys in place of the mouse for many ez-
Attendant call processing functions. Hot Keys, which involves pressing two (2) keys at the 
same time, are mapped to each feature shown under the Code Key Map option.
» To view these call features and their respective Hot Keys, go to the Menu bar and select: 

Setting > Code Key Map. The default mapping is shown in Table 2.

CONDITIONS

» Duplicate Hot Key mapping is not allowed.
» The keyboard “space bar” and “number keys” can not be used in a Hot Key map.

Table 2: Hot Key Default Map

FEATURE HOT KEY

Answer Alt + A

Call Back Alt + B

Call Pick-up (Direct) Ctrl + P

Camp On Alt + O

Clear Alt + X

CO Line Display (View) Alt + S

Conference Alt + C

Display Key Pad (Show) Ctrl + K

End Alt + E

Forward Alt + F

Hold Alt + H

Hunt Group Display Ctrl + G

Intrusion Alt + I

Mute Alt + M

Park Alt + P

Place Call Enter

Redial Alt + R

Search Ctrl + Enter

Search Next Ctrl + 

Search Previous Ctrl + 

Transfer Shift + Enter

UnPark Alt + U

Unscreened Transfer Alt + Enter
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16 ez-Attendant Configuration
Customize Environment

Using the Customize dialog box, Figure 19, operation of the ez-Attendant may be optimized for 
the user. There are three categories under the Customize dialog box which include settings 
for Outlook, Search options and enabling call logs and trace records.
» To enter parameters in the Customize dialog box, go to the Menu bar and select: Setting 

> Customize.

Figure 19: Customize Dialog Box

In the Outlook Setting section, select Outlook Auto Start to activate Outlook when the ez-
Attendant starts. Outlook will be started and minimized allowing the ez-Attendant quick access to 
the Outlook database. Schedule Auto Load will automatically update the ez-Attendant schedule 
files for other users at increments in the Time box using the path entered in the Path box.

The Search Order in the Search Setting section determines the order in which the ez-
Attendant will search for a phone number when the ez-Attendant user attempts to place a call 
from a Phone Book entry. The user may search through the several ez-Attendant databases. 
The characteristics of the search are defined in Search Option of the Search Setting section. 
Characters and Phone number can be set to perform a search for a given text/digit string in 
the search field from either the beginning of the field or contained anywhere within the field 
(sub characters). Use the drop-down selection menu to select the desired search option.

The Log View Setting and Trace Setting enable or disable storing call records and trace 
records for the ez-Attendant. Select the desired option.
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ez-Attendant Configuration 17
External Call Dial Codes

For proper operation of external calls, ez-Attendant must be assigned dial codes for CO Line 
access, International access, Local country code, etc.
» To enter parameters in the Code Setting dialog box, go to the Menu bar and select: 

Setting > Code Setting, Figure 20.

Figure 20: Code Setting Dialog Box

ez-Attendant PC to TeleniumIP Connection
ez-Attendant is connected to the host TeleniumIP system 
by way of the LAN (Local Area Network).

It is recommended that each ez-Attendant and the 
TeleniumIP system be connected to a 10/100 Base 
T Ethernet switch port.
The connection should use Category 5 straight 
through cable terminated in appropriate 
connectors, typically an RJ-45 connector, wired 
as shown in this diagram.

The Prefix code is also called the city or office code.
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18 ez-Attendant Operation
ez-Attendant Operation

Operation Overview
ez-Attendant is a software application designed to visualize attendant call processing and 
handling for the TeleniumIP system. The ez-Attendant application resides on the attendant's 
desktop and is accessed by the ez-Attendant short-cut icon on the Windows desktop. Opening 
the application, the Attendant logs on, establishing the link to the TeleniumIP over the LAN. The 
TeleniumIP configuration, station status, and other information are downloaded.

The ez-Attendant screen provides visual status of registered TeleniumIP users in the Station 
window with the Station Field View showing DSS/Status buttons. These buttons provide 
more detailed information on the status of users then available from the DSS/BLF buttons 
and LCD of normal multi-button phones by employing icons to denote status: Forward, DND, 
etc., combined with station name and number information. The alternative List View includes 
status icons for all users in a spreadsheet like list which can be viewed, edited, searched and 
used for placing calls. 
Incoming calls to ez-Attendant are displayed in the Queue window with Caller ID and queue 
time. When answered, the call information is shown in the Active Call window with additional 
information from comparison to the ez-Attendant Phone Book database. ez-Attendant can run in 
background, allowing the Attendant to employ other PC applications for word processing, etc. 
When a call is received while “minimized”, ez-Attendant delivers the call in a pop-up window, 
the user can answer and activate the ez-Attendant screen by 'clicking' the pop-up.
Transferring the call can be as simple as 'clicking' a button in the Station window or, 
entering a station number or name in the search box. Matches to the search entry displays 
detail from the Internal User Phone Book database and status from the TeleniumIP in the 
Information window. The Schedule window displays schedule information for the station from 
a public MS Outlook database and any active Text Message is displayed in the System Text 
Message window. Selecting the arrow button places a call to the selected user for transfer.
On screen buttons give easy access to commonly needed Attendant features such as 
Park, Paging, Camp on, Forward, Hold, Conference, etc. ez-Attendant affords access through 
the TeleniumIP to send SMS (Short Message Service) messages to other system users with an 
LCD multi-button phone, VODAVI DECT phone, ez-Phone or ez-Attendant. Incorporating a GSM 
modem in the PC, ez-Attendant can send and receive text messages over GSM mobile networks 
supporting SMS service. The ez-Attendant user can select recipients from the ez-Attendant 
databases (Phone Book, Log View or System Speed Dial) or, with the Keypad pop-up 
window, dial a number for ad-hoc calling.
ez-Attendant gives graphical access for Attendant system control functions commonly 
available through the multi-button phone including: Day/Night ringing activation, Attendant 
Cancel control, Call Forward, DND and System Text Messaging for other users, Temporary 
COS (Phone Lock), Date/Time, Wake-Up, etc. For each control function a dialog box is 
provided, allowing ez-Attendant user input. In addition, ez-Attendant can share, via the upload/
download utility, the TeleniumIP System Speed Dial database which permits the user to add or 
modify entries as well as search and place calls from the database.
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ez-Attendant maintains a database of External contacts which is accessed in the Station 
window Phone Book View. Entries in the Phone Book can be added, edited, search and used 
to place calls. The Phone Book is stored as either an MS Access file and is linked to the user 
Outlook, Goldmine or ACT! database using the import/export Tool.
ez-Attendant monitors and can log all external call activity of the TeleniumIP as well as internal 
calls to/from the ez-Attendant. This Log is shown in the Station window as the Log View in place 
of the Station Field or Phone Book View. As with other ez-Attendant databases, entries can be 
searched and used to place calls.
These and other operations are detailed in the following paragraphs referencing the ez-
Attendant screen as shown in Figure 21. The following illustration provides call-outs for each of 
the ez-Attendant screen windows, tool bars, etc.

Figure 21: ez-Attendant Screen
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Log on
Before starting Log on, ez-Attendant must be the active application. To start ez-Attendant double-
click the ez-Attendant shortcut icon on the Windows desktop.

To log on ez-Attendant, with ez-Attendant as the active screen, click the  icon on the 
right side of the Upper Tool bar of the ez-Attendant screen. The log on process can also be 
started with the Log On selection in the File menu, the Log-on Process window, Figure 22, 
will appear. The log on process includes download of various data files and configurations 
from the TeleniumIP and will require several minutes. The log on process may require 
additional time depending on traffic in the TeleniumIP system and the LAN.
Once complete, the  icon will change to  allowing easy log off.

Figure 22: Log-on Process Window

If the log on process is not successful, the LogOn Fail pop-up window, Figure 23 will appear 
with an error message indicating the cause of failure. Refer to Logon Error Messages on 
page 59 to view the various messages.

Figure 23: LogOn Fail Error Message Window
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When ez-Attendant is used with the TeleniumIP Hot Desk feature, the user must follow the Hot 
Desk log on procedure. The Hot Desk Password dialog box, Figure 24, will appear for 
password entry. When the password is correctly entered, select OK to proceed with the log 
on process.

Figure 24: Hot Desk Password Dialog Box

Answering Incoming Calls
ez-Attendant can answer calls in several ways depending on the state of the ez-Attendant 
application, active or minimized, and the extension receiving the call, ez-Attendant or another 
extension in the system.

ez-Attendant Minimized

When ez-Attendant receives an incoming call with the application minimized, the Incoming Call 
pop-up window, Figure 25, will appear. Selecting this window will answer the call and 
activate the ez-Attendant screen for further call processing. For further call processing options 
refer to Attendant Call Processing on page 24.

Figure 25: ez-Attendant Incoming Call Pop-Up Window
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ez-Attendant Screen Active

When ez-Attendant receives a call with the application active, the call information is displayed 
in the Queue window. Information provided depends on the Caller Id received with the call 
and may include the calling party name, number and length of time in queue.

Figure 26: Incoming Call Queue Window

The ez-Attendant user may answer a queued call by selecting the desired call using the mouse 
or using the “Call Answer” Hot Keys (default = ALT + A). Using the Hot Keys will answer the 
queued call shown at the top of the Queue window.
Once answered, information on the call is moved from the Queue window to the Active Call 
window just above the Queue window, Figure 27, and audio is sent to the Attendant's multi-
button phone. In addition to the Caller name, number and call duration, when CLI is provided 
and the call is from a caller registered in the Phone book, the Company name will be 
displayed. In addition, for recalls, the Active Call window will display the origin of the recall.

Figure 27: Active Call Window
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CONDITIONS

» Up to 20 calls can be queued to an Attendant in the TeleniumIP.
» If the Attendant is using another PC application when a new call arrives, the Incoming 

Call pop-up window will be displayed and can be used to activate the ez-Attendant and 
answer the call. Refer to ez-Attendant Minimized on page 21.

» The ez-Attendant user may answer a call in the traditional manner using the multi-button 
phone associated with ez-Attendant.

» When a call is answered by the ez-Attendant, a cursor appears in the Search box of the ez-
Attendant main screen in preparation for the Call Transfer operation. Refer to Transferring 
an Active Call on page 24.

Call Pick-Up

The ez-Attendant user can answer calls ringing at other extensions using Call Pick-Up. Tone 
ringing intercom calls, incoming CO line calls, recalling CO line calls and transferred CO line 
calls may be answered using the Pick-Up feature.

To answer a call using Pick-Up:

1. In the Station window, select the extension button with the incoming call,
-or-
In the Search box, enter the extension number.

2. Press the “Pick-Up” Hot Keys (default = CTRL + P).

CONDITIONS

» Call Pick-Up is subject to the conditions of the host TeleniumIP system.
EZ Attendant - Installer & User Guide October 2006



24 ez-Attendant Operation
Attendant Call Processing

Transferring an Active Call

ez-Attendant can send an active call to another extension or station group in the host TeleniumIP 
system. The transfer operation allows the ez-Attendant user to announce the call to the 
receiver and await a response. This is known as “Screened Call Transfer”. The Attendant 
need not announce or await a response, which is known as “Unscreened Call Transfer”.
Calls may be Transferred using the Station window buttons or entering search criteria in the 
Search entry box. A match to the entry is displayed in the Information window with user 
information as shown in Figure 28. In addition the user's schedule and text messages are 
displayed in the appropriate window. This information may be employed by the ez-Attendant 
user to more efficiently handle the call. ez-Attendant may also access the search function by 
pressing the “F2” keyboard button which will place the cursor in the search box.
If the intended receiver is busy, ez-Attendant may camp the call on the busy user, or use 
Intrusion to announce the call. Refer to Camp-on on page 25, and Intrusion on page 25.

To transfer an active call:

1. Select the desired station button in the Station window.
2. To screen the transfer, await answer and announce call.
3. Select  to complete the transfer.
-or-
Using the search function:
1. Select the  button and enter the search criteria,

-or-
Use the Hot Keys to view search information (default = CTRL + ENTER).

2. To transfer the call, select the  button.
3. To screen the transfer, await answer and announce call.
4. Select  to complete the transfer.

Figure 28:  Information Window Call Transfer
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CONDITIONS

» The search function will not provide information on the status of a Hunt Group and only 
unscreened transfers can be made to a Hunt Group.

» If multiple matches are found, the number of matches is shown and the user may review 
each match using the Search Hot Keys. The defaults are: CTRL +  for Search Previous, 
and CTRL +  for Search Next.

Camp-on

When transferring a call to or calling a busy extension, ez-Attendant can Camp the call on the 
busy extension sending a call camp-on tone to the user.

To Camp-on a call:

1. Receive busy signal on an internal call.
2. Press the  button below the Information window.

CONDITIONS

» Camp-on is subject to the conditions of the host TeleniumIP system.

Intrusion

When calling a busy extension, ez-Attendant may Intrude into the extension user's 
conversation to announce an important call, etc. Intrusion must be allowed in the host 
TeleniumIP system.

To Intrude on a conversation:

1. Receive busy on an internal call.
2. Press the  button below the Information window.

CONDITIONS

» Intrusion is subject to the conditions of the host TeleniumIP system.

Call Park and Retrieve

ez-Attendant may place a call into a Park state where the call is on hold and internal users can 
retrieve the call by dialing the Park Zone or orbit. This feature is often employed by an 
Attendant to Park a call and then page a user to pick-up the call from the Park Zone.

To Park a call:

Press the  button on the Lower Tool bar.
The call is placed on hold in the next available Park Zone and the Zone number is 
displayed in the optional Park window, Figure 29.

Figure 29: Park Window Display
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To retrieve a Parked call:

1. Activate the Keypad window (default Ctrl K).
2. Dial the Park Zone,

-or-
Select the desired Park Zone from the Park window.

Figure 30: Parked Call Access with Keypad Window

CONDITIONS 
» Call Park is subject to the conditions of the host TeleniumIP system.
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Paging

ez-Attendant can make announcements over the speakers of idle extensions and/or external 
announcement speakers. Extensions and speakers are arranged in groups called Page Zones. 
Extensions are arranged in Internal Page Zones, audio speakers are arranged in External 
Page Zones.
In the Paging window, Figure 31, ez-Attendant can select an individual zone, groups of zones or 
all zones to page simultaneously.

To place a page announcement:

1. Press the  button on the Upper Tool bar.
2. Select the desired zones in the Paging window, Figure 31.
3. Make announcement into the Attendant multi-button phone handset.
4. Hang-up.

Figure 31:  Page Zone Dialog Box

CONDITIONS

» Paging is subject to the conditions of the host TeleniumIP system.
EZ Attendant - Installer & User Guide October 2006



28 ez-Attendant Operation
Placing a Call
The ez-Attendant user has a number of mechanisms available to place calls. In addition to 
placing calls in the traditional manner from the Attendant multi-button phone, outgoing calls 
from ez-Attendant can be placed using any of the Station window tabs (Station Field, Phone 
Book and Log View) from the Search box, or from the Keypad window.

Station Window Station Field

To place a call from the Station Field view, merely click on the desired station button or, in 
the List view, double-click on the desired user record. ez-Attendant places the call with the 
audio to the Attendant multi-button phone.

Figure 32: Station Button and List View Display

Station Window Phone Book Tab

The Phone Book view, Figure 33, gives different views for each ez-Attendant database (Internal 
parties, External parties) and System Speed Dial numbers. Each or all ez-Attendant database 
groups can be displayed and searched for the desired number.

To place a call:

1. Select the radio button for the desired view.
2. Search the database using the 'Enter text here' cell at the top of each field by entering 

text or digits.
3. Double-click on the field with the desired phone or Speed Dial bin number, company, 

home, etc.
-or-
Double-click the user name.
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ez-Attendant will search the selected record for a phone number based on the search 
priority set in the Searching Order defined in the Customize dialog box, refer to 
Customize Environment on page 16.

Figure 33: Phone Book Internal and Speed Dial Fields

Station Window Log View

The Log View selects a log of external calls made or attempted by or to users of the host 
TeleniumIP system as well as internal calls from or to the ez-Attendant. ez-Attendant can view, 
search and select a call to any logged called or calling party.

To place a call:

1. Search the database using the “Enter text here” box at the top of each field by entering 
text or digits.

2. Double-click the field with the desired phone number, caller or called.

Figure 34:  Log View Fields
EZ Attendant - Installer & User Guide October 2006



30 ez-Attendant Operation
Keypad Window

ez-Attendant can make calls as if dialed from the Attendant's multi-button phone.

To place a call using the Keypad:

1. Press the “Show Keypad” Hot Keys (default = CTRL + K), to view the Keypad window. 
Figure 35

2. Dial the desired number, including any Line group access code required.
3. Select  or Call to place the call.

Figure 35: Keypad Window

CONDITIONS

» The conditions associated with placing a call from the Attendant's multi-button phone 
apply to calls made from the Keypad window.

» Hunt Groups can not be assigned a station button. Thus, to call a hunt group, the ez-
Attendant must use the Keypad window.

» The Keypad window can be used to call the last ez-Attendant dialed number, “Redial”, by 
selecting the Redial button in the Keypad window.

» The Clean button will remove the entire number if an error is made in the dialed number.

Message Wait/Call Back
When calling an extension that is busy, ez-Attendant may request a Call Back. If the extension 
is idle or in DND, the ez-Attendant can leave a Message Wait indication to the called extension.

To activate Message Wait or Callback:

1. Call an extension.
2. If no answer, busy signal, or DND signal is received, press the  button.

- If the extension is busy, Call Back is activated. When the called extension returns to 
idle, the system will notify the ez-Attendant with a Call Back. When ez-Attendant responds to 
the Call Back, the previously busy station is called.
- If the called extension is idle but does not answer or is in DND, the host TeleniumIP 
system will activate Message Waiting. When the called extension responds to the 
Message Wait indication, a call is placed to the ez-Attendant extension.

CONDITIONS

» Message Wait/Call Back is subject to the conditions of the host TeleniumIP system.
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Lower Tool Bar
The Lower Tool bar gives the ez-Attendant user convenient access to other call processing 
features of the host TeleniumIP system including Hold, Conference, Call Forward, Mute and 
End.

Hold Call

ez-Attendant can place calls on hold. The call will be placed on the preferred hold mode in the 
host TeleniumIP system database. Held calls are displayed in the Queue window with the hold 
Icon, Figure 36. After expiration of the Recall timer, the call recalls to ez-Attendant and the 
Recall Icon is displayed, Figure 37.

To place a call on hold:

Select the  button on the Lower Tool bar, or press the “Hold” Hot Key (default = 
ALT + H).

CONDITIONS

» Recall timers for Hold are assigned in the host TeleniumIP system.

Conference

The ez-Attendant user can join several parties in a conference call. A maximum of five parties 
can be joined with the ez-Attendant's multi-button phone in a conference.

To establish a Conference:

1. Place a call to the first party and press the  button. (The first caller is placed on 
hold.)

2. Place a call to the second party and press the  button. (The second caller is 
placed on hold.)

3. Repeat the process for additional parties.
4. After all parties have been called, press the  button again to establish the 

conference call and connect all parties.

CONDITIONS

» Conference is subject to the conditions of the host TeleniumIP system.

Figure 36: Hold Icon Figure 37: Recall Icon
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Call Forward

ez-Attendant can activate Call Forward, forwarding all calls to a pre-defined extension. The 
extension is assigned under the Setting menu, refer to Forward Information on page 12.

To activate Call Forward from ez-Attendant:

1. Select the  button on the Lower Tool bar to activate ez-Attendant Call Forward,
-or-
Select the  on the Upper Tool bar.

2. Select the Forward box from the My Status dialog box, Figure 38, to activate ez-Attendant 
Call Forward.

Figure 38: My Status Dialog Box

CONDITIONS

» Call Forward is subject to the conditions of the host TeleniumIP system.

Mute

While on an active call, ez-Attendant can mute the user's microphone so that the connected 
party can not hear the user. By activating Mute, all audio transmission from the user's phone 
is blocked.

To activate Mute:

Select the  button on the Lower Tool bar, the ez-Attendant multi-button phone is 
muted. 

End

ez-Attendant can terminate an activate call by selecting the  button on the Lower Tool 
bar. This action will terminate the call as if the handset on the multi-button phone were 
returned to the cradle.
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Tools Menu
The Tools menu allows ez-Attendant easy access to features generally programmable by the 
Attendant position including:

Station Name
Date and Time
BGM Source Selection
Station COS
Temporary COS
Pre-selected & Customized Messages

Station Name Change

ez-Attendant can assign or change the name associated with extensions in the host TeleniumIP 
system. This name is displayed in the LCD of other extensions when placing or receiving a 
call from the extension.

To assign an extension name:

1. From the Menu bar, select: Tools > Station Name.
2. Enter the desired extension number and name in their respective fields, Figure 39.
3. Click Apply or OK to save the entry.

Figure 39: Station Name Dialog Box

CONDITIONS

» Only English is supported for the Station Name.
» The Station Name may be up to 11 characters.
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Date/Time Change

If required, ez-Attendant can change the host TeleniumIP system date and time in the Date/Time 
dialog box.

To modify the Date or Time:

1. From the Menu bar, select Tools > Date/Time, Figure 40.
2. Select the month and date from the Calendar area.
3. Select the date display mode (day/month/year or month/day/year) in the Date area.
4. Enter the time and time display mode (12 or 24 hour) in the Time area.
5. Select OK.

Figure 40: Date/Time Dialog Box

CONDITIONS

» The Date/Time assignments are for the host TeleniumIP system and will not affect the
ez-Attendant PC.
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Text Messaging, Preselected & Custom

ez-Attendant can activate the host TeleniumIP System Text Messages (Preselected or Custom) for 
other extensions. When activated internal callers to the extension will receive the text 
message in the LCD of their multi button phone. Many of the Preselected (Fixed) Messages 
provide for the entry of additional characters to specify time, date, etc. Text Messaging is 
activated from the Message Type window, Figure 41.

To activate Text Messaging:

1. From the Menu bar, select Tools > Select Message Type.
2. Select the desired message type tab (Preselected or Customized), Figure 41.
3. Select the desired text message radio button or Remove Message button.
4. Enter the extension range in the Station boxes.
5. Click Apply or OK to activate.

Figure 41: Message and Type Selection Window
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When ez-Attendant calls a station with Text Messaging active, the message will display in the 
System Text Message window, Figure 42.

Figure 42: System Text Message Window Display

CONDITIONS

» Text messaging is subject to the conditions of the host TeleniumIP system.
» Selecting the Remove Button in the Message Type window will deactivate Text Message 

Forward.
ez-Attendant can access and edit the host TeleniumIP system's Customized Message table to 
enter or edit the Custom Messages. When activated, Custom Messages are sent to the LCD of 
callers' multi-button phones, ez-Phone user's screen and the ez-Attendant screen. Custom 
Messages are edited in the Custom Message window under the Setting menu.

To add or edit a customized message:

1. From the Menu bar, select Setting > Customized to view the Custom Message window, 
Figure 43.

2. Using the keyboard, enter message text.
3. When finished, click OK.

Figure 43: Custom Message Window

CONDITIONS

» Text Messaging is subject to the conditions of the host TeleniumIP system.
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Class of Service (COS)

Class Of Service Assignment
ez-Attendant can access the host TeleniumIP database to modify the COS (Class of Service) 
assignments of the system extensions. COS controls the external call dialing privileges for 
extensions. COS assignments are modified in the Change COS dialog box, Figure 44.

To modify a Class of Service:

1. From the Menu bar, select: Tools > Attendant > Change COS.
2. Enter the desired station range in the Station Range area, Figure 44.
3. Select the desired Day and/or Night COS desired in the COS Setting area.
4. Click Apply or OK to change the COS.

Figure 44: Change COS Dialog Box

CONDITIONS

» Extensions in the TeleniumIP system are subject to the COS dialing restrictions assigned.

Temporary COS (Phone Lock) -- Temporary COS is employed to temporarily block non-
authorized outgoing external calls. ez-Attendant can activate Temporary COS for other 
extensions which assigns the extension a COS level of 7. This effectively locks the phone by 
denying the extension the ability to access or dial on an outside CO Line. Temporary COS is 
activated in the Temporary COS dialog box, Figure 45.

To modify the Temporary COS:

1. From the Menu bar, select Tools > Attendant > Temporary COS.
2. Enter the desired station range in the Station Range area, Figure 45.
3. Select COS Down (Class 7) to activate Temporary COS, or COS Restore to restore the 

extension's normal COS level.
4. Click Apply or OK to save the entry.

Figure 45: Temporary COS Dialog Box
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Attendant Cancel

ez-Attendant can “cancel” certain features that may be active at one or more stations. Station 
features that are deactivated by Attendant Cancel include DND (Do Not Disturb), Call 
Forward, System Text Messaging and Wake-Up call. Attendant Cancel is located in the 
Attendant Cancel dialog box, Figure 46.

To deactivate a station feature:

1. From the Menu bar, select Tools > Attendant > Attendant Cancel.
2. Enter the desired station range in the Station Range area, Figure 46.
3. Click Apply or OK to save the entry.

Figure 46: Attendant Cancel Dialog Box

CONDITIONS

» The Attendant Cancel feature is subject to the conditions of the host TeleniumIP system.

BGM (Background Music) Selection

The host TeleniumIP system may provide multiple channels or sources for BGM (Background 
Music) which is played over the speakers of idle multi-button phones. ez-Attendant may select 
the source channel for BGM. This selection is made in the ICM BOX BGM Selection dialog box.

To change Background Music:

1. From the Menu bar, select Tools > Music Selection > BGM Music Selection.
2. Select desired channel from the drop-down menu in the Music Channel area, Figure 47.
3. When completed, click OK to change the Music Selection.

Figure 47: BGM Music Selection Dialog Box

CONDITIONS

» Music channels available are dependent on the host TeleniumIP system and installation.
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Upper Tool Bar Functions

Wake-up Call Registration/Cancel

A 'Wake-up call' or alarm can be set for an extension that will cause the system to ring the 
extension at the assigned time of day. The Wake-up can be a one-time event or may be 
repeated on a daily basis. ez-Attendant can set a Wake-up time for other extensions in the 
system in the Wake-Up dialog box Figure 48.

To set a Wake-up time:

1. Select the  button from the Upper Tool Bar to view the Wake-Up dialog box.
2. Select the desired user from the Category area.
3. Click the  button to select a user(s), or enter an extension number in the entry box.
4. Enter the desired time in the Time Setting area.
5. Select the appropriate radio button in the Alarm Type area: One Time, Continue or 

Remove.
6. Click Apply or OK to save the entry.

Figure 48: Wake-Up Dialog Box

CONDITIONS

» The maximum number of extensions that can be assigned to receive a Wake-Up signal at 
one time is based on limits of the host TeleniumIP system.
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Short Message Service (SMS)

Internal SMS -- ez-Attendant can send short messages, up to 48 characters to other internal 
system users equipped with a multi-button phone with display, VODAVI wireless DECT phone 
(Model GDC34X) or ez-Phone. When sent, the extension is notified of the message and the 
LCD or ez-Phone screen will display the message. ez-Attendant can also receive short 
messages from other ez-Attendants or ez-Phone users. Internal SMS messages are sent or 
received in the Private SMS window, Figure 49.

To send a Short Message:

1. From the Menu bar, select Tools > SMS > Private SMS, Figure 49.
2. Select the radio button for “SMS Send Window”.
3. Select the desired user from the Category area.
4. Select the  button to select a user(s), or enter an extension number in the Entry area 

box.
5. Enter the text message string in the “Message Text” window.
6. Press the Send button.

Figure 49: Private SMS Window

Received SMS messages are displayed in the SMS window of the ez-Attendant main screen and 
can also be viewed in the Private SMS window.
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To view the SMS messages from the Private SMS screen:

1. Select the radio button for “SMS Receive Window” to view received messages, Figure 50.
2. Use the Navigation buttons to review messages.

To delete a received message in the SMS Receive Window:

1. Select the desired message in the Message Text window.
2. Click Delete.

Figure 50: SMS to Keyset, Receive Message Window

CONDITIONS

» Internal SMS messages can be up to 48 characters in length.
» The ez-Attendant can store up to 30 received messages. Any additional messages received 

will automatically delete the oldest stored messages.

External SMS -- ez-Attendant will support GSM SMS (Short Message Service) when properly 
equipped with a GSM modem; refer to SMS Information on page 11. SMS messages can be 
sent to one or more GSM subscribers simultaneously. An ez-Attendant user can send SMS 
messages through several means including through the Tools menu, SMS on the Upper Tool 
bar, or directly from the Station window List Display, Phone Book or Log View. The basic 
steps are: enter the message, select a mobile subscriber, and send the message. Mobile SMS 
is managed through the Mobile SMS window, Figure 51.

To access the Mobile SMS window:

1. Select the  button on the Upper Tool bar,
-or-
Select the SMS option from the Tools menu,
-or-
Right-click the mouse on any Station window List Display, Phone Book, or Log View entry.

2. Select Mobile SMS from the selection menu to view the Mobile SMS window, Figure 51.
If not already selected, select the desired user from the Category area, 
-or-
Enter a user name or mobile number in the Entry box.

3. Select the Insert button.
4. Enter the text message string in the Message Text window.

Navigation
Buttons
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5. Press the Send button.

Figure 51: Mobile SMS Window

CONDITIONS

» ez-Attendant must be properly configured and equipped for access to a GSM modem, refer 
to SMS Information on page 11. 

My Status Ring Mode Control

ez-Attendant can control the Day/Night Ring mode of the host 
TeleniumIP system, placing the system in the Day, Night, 
Weekend, or Auto Ring Selection mode. Ring assignments for 
the mode selected are then enforced by the system. The Auto 
Ring Selection mode employs the system clock to shift from 
Day, Night and Weekend Ring modes based on the schedule 
assigned in the system database.
The Ring mode is controlled by the ez-Attendant in the My Status 
dialog box, Figure 52.

To access this dialog box:

1. Select the  button on the Upper Tool bar to view 
the My Status dialog box.

2. Select the radio button for the desired Ring mode.

Figure 52: My Status Dialog Box

CONDITIONS

» Ring assignments for the Day, Night and Weekend ring modes are made in the host 
TeleniumIP system database.

» The schedule for the Auto Ring mode is assigned in the host TeleniumIP system Database.

Entry
Area
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Send E-mail

The ez-Attendant user may send e-mails from the ez-Attendant screen using their normal e-mail 
client. E-mail recipients can be manually entered or selected from the Station window List 
Display or Phone Book entries. After selecting recipients, the user's normal e-mail client is 
invoked with the selected addresses entered automatically. The user may then enter the e-
mail text and send the mail in the normal manner. Recipients are entered from the E-Mail 
window, Figure 53.

To access the E-mail window:

1. Select the  button from the Upper Tool bar,
-or-
Select Send Mail from the Setting menu,
-or-
Right click on any entry in the Station window “List Display or Phone Book” with an e-mail 
address.

2. Select or enter the desired recipients.
3. Select Send to activate the e-mail client and proceed as normal for the e-mail client.

Figure 53: E-Mail Window

CONDITIONS

» The ez-Attendant supports Outlook or Outlook Express as the e-mail client.
» To improve execution speed, the e-mail client application should be running but 

minimized.
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CO Line Display Window
The ez-Attendant user has access to a CO Line Display pop-up window, Figure 54 using Hot 
Keys (default = ALT + S). In this window, ez-Attendant displays the status of all CO lines and 
permits the user to access a CO Line to answer or place external calls.

To answer or place a call:

1. To answer a call, enter the “Show CO Line” Hot Keys (default = ALT + S).
2. Select the desired CO Line to answer the call.
3. To place a call, if the CO Line is idle and Phone Number dialog box appears, enter the 

phone number and press ENTER, Figure 55.

Figure 54: CO Line Display Window

Figure 55: CO Line Display Window w/Phone Number Dialog Box

CONDITIONS

» Access to CO Lines is subject to the host TeleniumIP database.
» The Tool Tip window will display when the mouse pointer is moved over a CO Line icon.
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Hunt Group Information Window
The ez-Attendant SMS window is shared with the Hunt Group Information window. The Hunt 
Group Information window, Figure 56, shows the Hunt Group Number, number of incoming 
calls, and the CO Line number.

To toggle between the SMS & Hunt Group windows:

Press the “Show Hunt Group” Hot Keys (default = CTRL + G).

Figure 56: Hunt Group Information Window]

This display shows Hunt Group 620 has one incoming call on CO Line 38 and CLI will be 
shown when provided.

Phone Book
The ez-Attendant Phone Book gives the user an extension database, external (customer) 
database. It also gives access to the host TeleniumIP System Speed Dial database. The ez-
Attendant user databases are stored in an *.mdb format. Other database formats (Outlook, 
Excel, Goldmine and ACT!) are supported via the Import/Export utility. The Phone Book 
database can be used with a number of other ez-Attendant features, thus an accurate timely 
database is important for efficiency. Refer to Figure 57.

The database fields include the following criteria:
STN (extension number or blank for an external contact)
First Name
Last Name
Company
Home (telephone number)
Mobile phone number
Job title (Ex: manager, engineer, etc.)
Fax number
Business telephone number (office telephone number)
Address
E-mail address
Nick name
System Speed Dial bin number from host TeleniumIP system
Memo
Department
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To access the Phone Book window:

Select the Phone Book tab in the Station window,
-or-
Press the [F4] key.

To search for a Phone Book entry:

Enter the search text for the appropriate field in the “Enter text here” cell.

To delete a Phone Book entry:

Select the desired entry and click the  button.

Figure 57: Phone Book Window

CONDITIONS

» The ez-Attendant user may add (register) or edit Phone Book entries, refer to Add/Edit 
Phone Book Entries on page 47

» The “All” radio button option in the Phone Book window applies to the internal and 
external databases and does not include the host TeleniumIP System Speed Dial database.

» Moving from system to system makes changes in Phone Book
The Phone Book entries only apply to a specific system; the phone book is not an 
independent database, but instead is tied to the list of stations in the TeleniumIP system.
ez-Attendant is intended to be an operator console, not a system management tool for 
multiple unconnected systems.
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Add/Edit Phone Book Entries

The ez-Attendant user can add (register) or edit Phone Book entries with the Register and Edit 
dialog box, Figure 58.
All phone numbers should be entered in the following format:

Phone numbers should begin with a “+” followed by the country code.
The country code should be followed by a space.
The area code should be enclosed in parenthesis.

To add or edit the Phone Book,

1. Select the Register or Edit button from the Phone Book window, see Figure 57.
2. To view the Register and Edit dialog box, Figure 58, enter data for the contact.
3. After completing the entry, click Apply to continue entering data,

-or-
Click OK to save the data and return to the ez-Attendant main screen.

Figure 58: Register/Edit Phone Book Entry Window
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To assist the user in proper entry, the Check Phone Number dialog box can be accessed by 
double-clicking on the desired entry box in the Register and Edit dialog box. This will reveal 
the Check Phone Number dialog box, Figure 59.

Figure 59:  Check Phone Number Dialog Box

CONDITIONS

» For proper interpretation and operation, phone numbers must be entered in the correct 
format.

» The “Speed No” field in the Register and Edit dialog box is the System Speed Dial bin 
number, if any, associated with the contact.

Phone Book Database Link

The Phone Book database uses the Microsoft Access format, and an Import/Export facility is 
provided to use other formats including Goldmine, ACT!, Outlook and Excel. The database, 
ATD.mdb, must exist in the ez-Attendant folder along with the ez-Attendant executable file in 
order to view and modify the contents.

To add a new database file:

1. From the Main Menu, select File > New DB, (a “blank” Phone Book will appear).
2. Enter the desired contact information, or select a database file to import.

To import a Microsoft Outlook contact database:

1. From the Main Menu bar, select File > Import DB.
2. Select the proper file type from the Import DB menu, one of the windows shown in Figure 

60 will appear.
EZ Attendant - Installer & User Guide October 2006



ez-Attendant Operation 49
3. Select the desired contact database file, or change the path to locate the file if needed.

Figure 60: Contact Database Window

In addition to the contact database, the Outlook Schedule file can be imported manually. 
Normally, this file is downloaded periodically as described in Customize Environment on 
page 16.
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To import the Outlook schedule file:

1. From the Menu bar, select File > Import DB > Microsoft Outlook Schedule. The Outlook 
Setting window will appear, Figure 61.

2. Select the desired schedule (calendar) file from Outlook Setting window, or change the 
path to locate the file if needed.

Figure 61: Outlook Setting Window - Calendar

CONDITIONS

» To use the Import/Export facility, the database can not be in use by another application. 
Attempts to import or export will return an Operating System error message.

» Import or export to a GoldMine or ACT! Database file can only be accomplished if there is 
no user logged on the ez-Attendant.

» The file extension for each file type is:
Outlook - not shown
GoldMine or ACT! - *.DBF
Access - *.mdb
Excel - *.xls

» When importing a Microsoft Outlook Schedule, only schedules for users registered in the 
Phone Book will be imported.
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System Speed Dial Window

ez-Attendant allows the user access to the host TeleniumIP System Speed Dial database. The user 
can download the database from the host TeleniumIP system, add or modify entries and upload 
selected entries. In addition the user can search the database and use entries to place calls. 
To access the System Speed Dial database, select the Speed radio button in the Phone Book 
window, Figure 62.

Figure 62: Speed Dial Database

The database must be downloaded before it can be viewed. To download the System Speed 
Dial database to the ez-Attendant, select the Download button. The TeleniumIP will send the 
System Speed Dial database to the ez-Attendant. The transfer will require several minutes and 
will be affected by the number of Speed Dials in use, LAN and TeleniumIP traffic, etc.
During the download process ez-Attendant displays the download status and cancel button, 
Figure 63. Selecting this button during the download will terminate the download process.

Figure 63: Download Status/Cancel Button

To add or edit an entry:

1. Select the desired entry.
2. Enter data in the Register/Edit area, lower section of the window.
3. Select upload to send the modification to the TeleniumIP database.
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To delete a System Speed Dial number:

Select the desired entry and click Delete to remove the record.

To search the database:

Enter characters and/or digits in the “Enter text here” cell.

CONDITIONS

» TeleniumIP supports only one download process at a time. A second request will return the 
“You cannot do up/download now.” error message.

» Multiple records can be selected for upload or download using the “Shift” or “Ctrl” keys.
» If the data entered in the System Setting for Speed does not agree with the actual 

connected, refer to System Setting for LogOn on page 10. TeleniumIP, upload/download is 
not allowed. The System Setting for Speed must be corrected. This may only be 
accomplished with the ez-Attendant in the logged off mode.

Log View
ez-Attendant maintains a log of all external call activity from the host TeleniumIP system. The Log 
View data can be searched, filtered, printed, saved and records deleted. Each Log View 
record contains the following fields:

 

Log View Field Description

Status Type of call (incoming/outgoing, internal/external)

Caller Caller identification

Caller Name Name of the calling party

Called Telephone number called

Called Name Name of the called party

DID DID number dialed

DID Name Name associated with DID number

Date Date call was made

Time Time call was placed

Duration Duration of call in minutes and seconds (00:00)

Queue Time Duration the call rang into the TeleniumIP system prior to 
answer/disconnect

I/O Port designation

Ext/Int External or Internal call

Ans/Noans Answered or not answered
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The Log view is selected in the Station window by selecting the Log View tab. 

Figure 64: Log View Station Window

To filter the Log View data:

1. Select the All Logs button to assure accuracy of the database.
2. Enter a FROM and TO date, these are needed for proper search operation.
3. Select filter items from list, enter phone number for Caller/Called number, if selected.

To search the Log View:

Enter the text in the “Enter text here” cell.

To place a call using an entry:

Double-click the Caller or Called entry.

To delete a Log View record:

Select the desired record and press the Del button.

To print a Log View:

Select Print from the Upper Tool bar,
-or-
Select File on the Menu bar, and click Print.

CONDITIONS

» All external calls placed or received by the system as well as internal calls to or from the 
ez-Attendant are recorded.

» Records in the Log View are stored in the ATD.mdb file. When the records are saved using 
the Save as function, the records are deleted from the ATD.mdb file and stored as an 
*.xls file in the file name entered.

» Using the File menu for print allows access to the Print Setup menu.
» The ez-Attendant log will store up to 10,000 call records; additional records overwrite the 

oldest records.
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General

Tool Tip Display

When the mouse pointer is moved over an Upper or Lower Tool Icon, the Tool Tip window will 
open indicating the Hot Key combination which will activate the associated feature. 
Additional information is also provided when the mouse pointer is placed over an extension 
button in the Station window, Figure 65. The information shown includes extension status, 
Wake-up setting, active Text message, Call forward state, and active call information.

Figure 65: Tool Tip Window

CONDITIONS

» The Tool Tip window is only provided with the button icon display views of the Station 
window.

Record VMIB

In order to operate this feature, you must be using the TeleniumIP VSF as your voice mail 
system. ez-Attendant can be used to access the host TeleniumIP system VMIB so that the user 
may record an outgoing message for the Attendant extension. This message is played to 
callers who are connected to the VMIB to leave a voice mail message for the Attendant. Once 
connected to the VMIB, the user employs the Attendant multi-button phone handset to 
record the greeting.

To record a greeting:

1. Select Setting from the Menu bar.
2. Select Record VMIB from the Setting menu.
3. With the multi-button phone handset, record the greeting.
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Multiple ez-Attendants

The TeleniumIP can support up to five (5) ez-Attendants which are assigned in the Attendant 
Group or ICM Tenant Group programs of the TeleniumIP, PGM codes 164 and 120 respectively. 
When multiple Attendants are assigned, separate ez-Attendants can be logged on to each 
Attendant extension assigned in the host TeleniumIP database.

Flexible Button Programming

Using the Setting menu, the ez-Attendant user can assign functions to the Flex buttons of 
multi-button phones connected to the TeleniumIP system. Flex button assignment is similar to 
the TeleniumIP Admin Program 115 and is managed in the Flex Buttons Setting dialog box.

To assign Flex buttons:

1. From the Main Menu, select Setting/Flex Buttons Setting, Figure 66.
2. Enter the desired Station Range.
3. To download the Flex button data, click Read and select the desired Flex Button.
4. To view the Flex Button assignment dialog box, click Setting, Figure 67.

a. Select the button Type from the drop-down menu.
b. Enter any Data required for the button type assigned.
c. Click Apply or OK to store the new data.

CONDITIONS

» The Flex button data shown in the Flex Buttons Setting dialog box is representative of the 
lowest station number in the range entered.

» The conditions of the TeleniumIP system apply to ez-Attendant Flex Button assignments.

Figure 66: Flex Buttons Setting Dialog Box Figure 67: Flex Button Assignment
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Networking

ez-Attendant can operate in a network environment where multiple TeleniumIP systems are 
interconnected over an IP network.
ez-Attendant may also call unregistered network stations by including “n” as a prefix to the 
network station number when using the Search box to place the call.
Network stations may also be assigned to a 'network group'. A network group is assigned 
under the Group Setting dialog box with the prefix “N_”, refer to Station Window Display 
Groups on page 13. For example, a network group would be assigned the group name 
“N_Labs”, as shown in Figure 68. Any network station can then be assigned to the network 
group including stations from different nodes of the network.

Figure 68: Network Station Group

CONDITIONS

» A maximum of 50 stations for each network node can be registered in ez-Attendant.

Alarm Information Window
Alarms from the host TeleniumIP system are sent as a pop-up, Figure 69, to ez-Attendant as well 
as the LCD of the Attendant multi-button phone.

Figure 69: Alarm Information Window

When received, the ez-Attendant user may send the Alarm message to another extension or 
Mobile user as an SMS message.

CONDITIONS

» Alarm messages are subject to the conditions of the host TeleniumIP system.
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Shared MS Outlook Schedules

Outlook Database
ez-Attendant can display the schedules of registered users maintained in a shared Outlook 
database. The Outlook database must be located in an Exchange server. The schedule 
information is shown in the Schedule window when a user name is entered in the Search box 
on the ez-Attendant main screen, and the Search icon is selected, Figure 70.

Figure 70: User Schedule Display

The shared database can be imported to the ez-Attendant database manually as described 
in Phone Book Database Link on page 48.
The database may also be imported automatically based on the settings as described in 
Customize Environment on page 16.
In either case, all schedules in the path defined will be imported for all registered users 
for both attendees and hosts.
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Outlook Setup in Exchange Server
To operate properly, users must maintain schedules in a Public folder in an Exchange Server. 
The following scenario shows the set-up of the Outlook Public folders in the Exchange server.

Example

1. Run the MS Outlook program.
2. Create a folder named “Schedules” to contain appointments.
3. Under the Schedules folder, create a folder for each user.

Figure 71: Outlook Scheduler Folders

After creating folders for all users, the Schedules folder tree will appear as shown.
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Program Information

Local Language
The following illustration shows the text file used for the displays of menus, tool bars, etc. 
Using a text editor, a Local Language can be supported. (c:\ezattendant\Install\pcatdlls.txt)

Logon Error Messages
The following messages may appear should the logon process fail, see Log on on page 20.

No Lock key for ez-Attendant. Please Contact your local dealer!
TeleniumIP System is initializing.
Same attendant number already logged on by another one.
ATD port is not available: There is no available attendant. All attendants are logged on.
The number sent is not valid ATD number: Check the PGM 164.
“This agent attendant is not logon to dummy station.”-> the station to use agent 
attendant is not logged on.
“This dummy station can not be logon to the system.” The dummy station number cannot 
be log on.
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ez-Attendant Icons

Station Window Icons

Queue Window Icons

CO Line Status Icons

DKTU-Busy (blue)

SLT-Busy (blue)

WHTU-Busy (blue)

DND State

Network STN-Busy (blue)

Network STN-DND

DKTU-Idle (white)

SLT-Idle (white)

WHTU-Idle (white)

Forward State

Network STN-Idle (white)

Pre-selected Message, 
(Button Icon only)

ICM Incoming (yellow)

Attendant Recall (red)

Park Recall (orange)

Park

CO Incoming (green)

Hold Recall (green)

Transfer Recall (blue)

Hold State

Invalid CO Line

Transfer Hold CO Line

Idle CO Line

Busy CO Line

 

EZ Attendant - Installer & User Guide October 2006


	ez-Attendant Installation & User Guide
	Revisions/Copyright
	Contents
	Product Description
	PC Interface
	Database Functionality

	Installation
	PC Requirements
	System Requirements
	Port Connection
	Software Version
	IP Address
	Multiple Systems

	Installation Routine
	DAO Install
	ez-Attendant Install


	ez-Attendant Configuration
	Navigating in the Program Window
	File Menu
	Tools Menu
	Setting Menu
	Help Menu

	Program Overview
	Display Window
	Station Type
	Station Window Size
	Station View
	Park Call Display Window
	Keypad Display
	Language Selection (not available)

	Settings Window
	System Setting for LogOn
	Log On Information
	SMS Information
	Forward Information
	Group Setting Information

	Other Functions
	Station Window Display Groups
	Hot-Key Map Configuration
	Customize Environment
	External Call Dial Codes

	ez-Attendant PC to TeleniumIP Connection

	ez-Attendant Operation
	Operation Overview
	Log on
	Answering Incoming Calls
	ez-Attendant Minimized
	ez-Attendant Screen Active
	Call Pick-Up

	Attendant Call Processing
	Transferring an Active Call
	Camp-on
	Intrusion
	Call Park and Retrieve
	Paging

	Placing a Call
	Station Window Station Field
	Station Window Phone Book Tab
	Station Window Log View
	Keypad Window

	Message Wait/Call Back
	Lower Tool Bar
	Hold Call
	Conference
	Call Forward
	Mute
	End

	Tools Menu
	Station Name Change
	Date/Time Change
	Text Messaging, Preselected & Custom
	Class of Service (COS)
	Attendant Cancel
	BGM (Background Music) Selection

	Upper Tool Bar Functions
	Wake-up Call Registration/Cancel
	Short Message Service (SMS)
	My Status Ring Mode Control
	Send E-mail

	CO Line Display Window
	Hunt Group Information Window
	Phone Book
	Add/Edit Phone Book Entries
	Phone Book Database Link
	System Speed Dial Window

	Log View
	General
	Tool Tip Display
	Record VMIB
	Multiple ez-Attendants
	Flexible Button Programming
	Networking

	Alarm Information Window

	Shared MS Outlook Schedules
	Outlook Database
	Outlook Setup in Exchange Server

	Program Information
	Local Language
	Logon Error Messages
	ez-Attendant Icons
	Station Window Icons
	Queue Window Icons
	CO Line Status Icons




